41 lines
1.1 KiB
Nix
41 lines
1.1 KiB
Nix
{
|
|
description = "NixOS configuration flake";
|
|
|
|
inputs = {
|
|
nixpkgs.url = "github:NixOS/nixpkgs/nixos-24.05";
|
|
home-manager.url = "github:nix-community/home-manager/release-24.05";
|
|
home-manager.inputs.nixpkgs.follows = "nixpkgs";
|
|
nixos-generators = {
|
|
url = "github:nix-community/nixos-generators";
|
|
inputs.nixpkgs.follows = "nixpkgs";
|
|
};
|
|
};
|
|
|
|
outputs = { self, nixpkgs, home-manager, nixos-generators,...}:
|
|
let
|
|
system = "x86_64-linux";
|
|
pkgs = nixpkgs.legacyPackages.${system};
|
|
in {
|
|
nixosConfigurations = {
|
|
lift = nixpkgs.lib.nixosSystem {
|
|
inherit system;
|
|
modules = [
|
|
./configuration.nix
|
|
./sway.nix
|
|
./hardware-configuration.nix
|
|
];
|
|
};
|
|
};
|
|
homeConfigurations = {
|
|
rothe = home-manager.lib.homeManagerConfiguration {
|
|
inherit pkgs;
|
|
modules = [ ./home/rothe.nix ];
|
|
};
|
|
};
|
|
box = nixos-generators.nixosGenerate {
|
|
system = "x86_64-linux";
|
|
format = "vm";
|
|
};
|
|
};
|
|
}
|