68 lines
2.0 KiB
Nix
68 lines
2.0 KiB
Nix
{
|
|
description = "NixOS configuration flake";
|
|
|
|
inputs = {
|
|
disko.url = "github:nix-community/disko";
|
|
nixpkgs.url = "github:NixOS/nixpkgs/nixos-24.11";
|
|
home-manager.url = "github:nix-community/home-manager/release-24.11";
|
|
home-manager.inputs.nixpkgs.follows = "nixpkgs";
|
|
sops-nix.url = "github:mic92/sops-nix";
|
|
};
|
|
|
|
outputs = inputs@{ self, nixpkgs,...}:
|
|
let
|
|
system = "x86_64-linux";
|
|
pkgs = nixpkgs.legacyPackages.${system};
|
|
in {
|
|
nixosConfigurations = {
|
|
lift = nixpkgs.lib.nixosSystem {
|
|
inherit system;
|
|
modules = [
|
|
./configuration.nix
|
|
./sway.nix
|
|
./hardware-configuration.nix
|
|
];
|
|
};
|
|
tien = nixpkgs.lib.nixosSystem {
|
|
system = "x86_64-linux";
|
|
specialArgs = { inherit inputs; };
|
|
modules = [
|
|
inputs.disko.nixosModules.disko
|
|
./vps-configuration.nix
|
|
./vps-hardware-configuration.nix
|
|
];
|
|
};
|
|
};
|
|
homeConfigurations = {
|
|
"rothe@lift" = inputs.home-manager.lib.homeManagerConfiguration {
|
|
inherit pkgs;
|
|
modules = [
|
|
./home/rothe.nix
|
|
./home/wayland
|
|
];
|
|
extraSpecialArgs = {
|
|
mail = nixpkgs.lib.strings.concatStrings ["mail" "@" "johannes-rothe.de"];
|
|
};
|
|
};
|
|
"rothe@johannes-powermachine" = inputs.home-manager.lib.homeManagerConfiguration {
|
|
inherit pkgs;
|
|
modules = [
|
|
./home/rothe.nix
|
|
];
|
|
extraSpecialArgs = {
|
|
mail = nixpkgs.lib.strings.concatStrings ["mail" "@" "johannes-rothe.de"];
|
|
};
|
|
};
|
|
"rothe@pdemu1cml000301" = inputs.home-manager.lib.homeManagerConfiguration {
|
|
inherit pkgs;
|
|
modules = [
|
|
./home/rothe.nix
|
|
];
|
|
extraSpecialArgs = {
|
|
mail = nixpkgs.lib.strings.concatStrings ["rothe" "@" "magazino.eu"];
|
|
};
|
|
};
|
|
};
|
|
};
|
|
}
|